عیب یابی پروتکل مسیریابی RIP

عیب یابی پروتکل مسیریابی RIP

هدف از  مقاله عیب یابی پروتکل مسیریابی RIP، پیکربندی روتر با پروتکل مسیریابی RIP و بررسی فعالیت پروتکل مسیریابی RIP با دستور debug ip rip می باشد.

تجهیزات مورد نیاز دو عدد روتر سیسکو، دو عدد سوئیچ سیسکو 2960 و 2 عدد PC می باشد.

 

بعد از پیکربندی پروتکل مسیریابی RIP ممکن است با اشکالات مختلفی روبه رو شوید که باید با اصول عیب یابی این پروتکل و کار با بسیاری از دستورات عیب یابی و همچنین نحوه کار با دستور debug آشنا شوید.

 

تنظیمات اینترفیس های روتر1 و روتر2:

عیب یابی پروتکل مسیریابی RIP

 

تنظیمات کامپیوتر PC1:

عیب یابی پروتکل مسیریابی RIP

 

تنظیمات کامپیوتر PC2:

عیب یابی پروتکل مسیریابی RIP                                                                                                                                                                                                                                             

 مرحله 1: پیکربندی روتر1 و روتر2 و تنظیم IP Address بر روی اینتفریس های روتر

برای پیکربندی اینترفیس FastEthernet 0/0 بر روی روتر1 دستورات زیر را اجرا کنید.

 

Router1(config)#interface serial 0/0

Router1(config-if)#ip address 192.168.14.1 255.255.255.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

 

برای پیکربندی اینترفیس Serial 0/0 بر روی روتر1 دستورات زیر را اجرا کنید.

Router1(config)#interface serial 0/0

Router1(config-if)#ip address 192.168.15.1 255.255.255.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

 

برای پیکربندی اینترفیس FastEthernet 0/0 بر روی روتر 2 دستورات زیر را اجرا کنید.

Router2#config t

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ip address 192.168.16.1 255.255.255.0

Router2(config-if)#no shutdown

 

برای پیکربندی اینترفیس Serial 0/0 بر روی روتر 2 دستورات زیر را اجرا کنید.

Router2(config)#interface Serial 0/0

Router2(config-if)#ip address 192.168.15.2 255.255.255.0

Router2(config-if)#no shutdown

 

 

 

 

مرحله 2: پیکربندی پروتکل مسیریابی RIP بر روی روتر 1 و روتر2

با استفاده از دستورات زیر پروتکل مسیریابی RIP را بر روی روتر 1 تعریف خواهیم کرد.

 

Router1#config t

Router1(config)#Router rip

Router1(config-router)#network 192.168.14.0

Router1(config-roter)#network 192.168.15.0

Router1(config-roter)#exit

Router1(config)#exit

با استفاده از دستورات زیر پروتکل مسیریابی RIP را بر روی روتر2 تعریف خواهیم کرد.

Router2#config t

Router2(config)#Router rip

Router2(config-router)#network 192.168.15.0

Router2(config-roter)#network 192.168.16.0

Router2(config-roter)#exit

Router2(config)#exit

 

با دستور زیر پیکربندی های موجود در حافظه RAM برای ذخیره همیشگی به داخل حافظه NVRAM کپی خواهد شد.

Router2#copy running-config startup-config

 

مرحله 3: استفاده از دستور debug ip rip

دستور Debug فعالیت های پشت پرده که در حالت عادی شما آنها را مشاهده نمی کنید را در خروجی به شما نمایش خواهد داد.

به این نکته توجه کنید که استفاده از دستور debug باعث افزایش شدید بار پردازشی روتر خواهد شد و فقط در یک مقطع زمانی کوتاه برای عیب یابی مورد استفاده قرار خواهد گرفت و در پایان این باید کلیه پردازش های مربوط به Debug را غیر فعال کنید.

 

برای مشاهده فعالیت پروتکل IP با جزئیات، دستور debug را همراه با پارامترهای مربوط به آن به صورت زیر بر روی روتر1 اجرا کنید.

 

Router1#debug ip rip

RIP protocol debugging is on

Router#RIP:sending v1 update to 255.255.255.255 via FastEthernet 0/0

(192.168.14.1)

RIP:build update entries

Network 192.168.15.0 metric 1

Network 192.168.16.0 metric 2

RIP:sending v1 update to 255.255.255.255 via Serial 0/0)192.168.15.1)

RIP: build update entres

Network 192.168.14.0 metric 1

RIP:received v1 update from 192.168.15.2 on Serial 0/0

192.168.16.0 in 1 hops

RIP: Sending v1 update to 255.255.255.255 via FastEthernet 0/0 )192.168.14.1)

RIP:build update entries

Network 192.168.15.0 metric 1

Network 192.168.16.0 metric 2

RIP:Sending v1 update to 255.255.255.255 via Serial 0/1/0)192.168.15.1)

RIP:build update entries

Network 192.168.14.0 metric 1

بعد از اجرای دستور debug ip rip به خروجی آن و قسمت های مشخص شده با دقت توجه کنید مشاهده می کنید که کلیه اطلاعاتی که توسط پروتکل RIP ارسال و دریافت می شود در خروجی دستور نمایش داده شده است.

دستور debug ip rip باعث می شود روتر، عوامل پشت پرده و اطلاعات مسیریابی و به روزرسانی های که بین روتر 1 و روتر2 رد و بدل می شود را نمایش دهد و شما می توانید از این اطلاعات برای عیب یابی پروتکل مسیریابی RIP استفاده کنید.

مقاله مرتبط :

پیکربندی پروتکل مسیریابی RIP در IPV6

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0