مدیریت و عیب یابی پروتکل مسیریابی OSPF

هدف از این مقاله:

مدیریت و عیب یابی پروتکل مسیریابی OSPF

تجهیزات مورد نیاز برای مدیریت و عیب یابی پروتکل مسیریابی OSPF:

تنظیمات مربوط به اینترفیس های Router1  را در جدول زیر مشاهده می کنید.

Interface Type Serial Subnet MaskIP AddressInterface
-255.255.255.0 192.168.2.1FastEthernet 0/0
DCE255.255.255.0192.168.0.1Serial 2/0

تنظیمات مربوط به اینترفیس های Router2  را در جدول زیر مشاهده می کنید.

Interface Type Serial Subnet MaskIP AddressInterface
- 255.255.255.0192.168.3.1FastEthernet 0/0
DTE255.255.255.0192.168.0.2Serial 2/0
DCE255.255.255.0192.168.1.1Serial 3/0

تنظیمات مربوط به اینترفیس های Router3  را در جدول زیر مشاهده می کنید.

Interface Type Serial Subnet MaskIP AddressInterface
- 255.255.255.0 192.168.4.1FastEthernet 0/0
DTE 255.255.255.0192.168.1.2 Serial 2/0

تنظیمات مربوط به اینترفیس های Switch 1  را درجدول زیر مشاهده می کنید.

CommandInterface
Router 1 FastEthernet 0/1
PC 1 FastEthernet 0/2
PC 2 FastEthernet 0/3

تنظیمات مربوط به اینترفیس های Switch 2  را درجدول زیر مشاهده می کنید.

CommandInterface
Router 2 FastEthernet 0/1
PC 3 FastEthernet 0/2
PC 4FastEthernet 0/3

تنظیمات مربوط به اینترفیس های Switch 3  را درجدول زیر مشاهده می کنید.

CommandInterface
Router 3FastEthernet 0/1
PC 5 FastEthernet 0/2
PC 6FastEthernet 0/3

 

تنظیمات کامپیوتر PC1 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.2.1 255.255.255.0 192.168.2.2 PC1

 

تنظیمات کامپیوتر PC2 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.2.1 255.255.255.0 192.168.2.3PC2

 

تنظیمات کامپیوتر PC3 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.3.1255.255.255.0 192.168.3.2PC3

 

تنظیمات کامپیوتر PC4 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.3.1255.255.255.0192.168.3.3 PC4

 

تنظیمات کامپیوتر PC5 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.4.1255.255.255.0192.168.4.2PC5

 

تنظیمات کامپیوتر PC6 :

Default Gateway Subnet Mask IP Address Computer Name
192.168.4.1255.255.255.0192.168.4.3PC6

 

در مدیریت و عیب یابی پروتکل مسیریابی OSPF قصد داریم دستورات مدیریتی و عیب یابی مربوط به پروتکل مسیریابی OSPF را بررسی کنیم.

 

مرحله ی 1: پیکربندی تنظیمات IP Address بر روی Router1 و Router2 و Router3

 پیکربندی اینترفیس FastEthernet0/0 روتر Router1 :

Router1#config t

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ip address 192.168.2.1 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router1 :

 

Router1(config)#interface serial 2/0

Router1(config-if)#ip address 192.168.0.1 255.255.255.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet0/0 روتر Router2 :

 

Router2#config t

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ip address 192.168.3.1 255.255.255.0

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet1/1 روتر Router2 :

 

Router2#config t

Router2(config)#interface fastEthernet 1/1

Router2(config-if)#ip address 192.168.10.2 255.255.255.0

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router2 :

 

Router2(config)#interface serial 2/0

Router2(config-if)#ip address 192.168.0.2 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial3/0 روتر Router2 :

 

Router2(config)#interface serial 3/0

Router2(config-if)#ip address 192.168.1.1 255.255.255.0

Router2(config-if)#clock rate 64000

Router2(config-if)#no shutdown

پیکربندی اینترفیس FastEthernet0/0 روتر Router3 :

Router3#config t

Router3(config)#interface fastEthernet 0/0

Router3(config-if)#ip address 192.168.4.1 255.255.255.0

Router3(config-if)#no shutdown

پیکربندی اینترفیس Serial2/0 روتر Router3 :

 

Router3(config)#interface serial 2/0

Router3(config-if)#ip address 192.168.1.2 255.255.255.0

Router3(config-if)#no shutdown

 

مرحله 2: پیکربندی پروتکل مسیریابی OSPF بر روی Router1 و Router2 و Router3

در این مرحله پروتکل مسیریابی OSPF را در محیط Single Area پیکربندی خواهیم نمود توجه داشته باشید که در این مقاله کلیه Routerهای ما در Area 0 یا همان Backbone Area قراردارند.

 

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router1:

 

Router1#config t

Router1(config)#router ospf 10

Router1(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router1(config-router)#network 192.168.2.0  0.0.0.255 area 0

Router1(config-router)#exit

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router2:

 

Router2#config t

Router2(config)#router ospf 10

Router2(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.3.0  0.0.0.255 area 0

Router2(config-router)# exit

 

 

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router3:

 

Router3#config t

Router3(config)#router ospf 10

Router3(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router3(config-router)#network 192.168.4.0  0.0.0.255 area 0

Router3(config-router)#exit

 

 

مرحله 3: استفاده از دستورات Show برای مشاهده اطلاعات و پیکربندی های مربوط به پروتکل مسیریابی OSPF

دستورات Show برای مشاهده اطلاعات مربوط به پروتکل مسیریابی OSPF استفاده خواهد شد لیستی از دستورات مربوط به نمایش اطلاعات پروتکل مسیریابی OSPF را در جدول زیر مشاهده می کنید.

تشریح CommandCommand
این دستور کلیه پروتکل های مسیریابی که بر روی Router فعال می باشند را نمایش می دهدRouter show ip protocols
این دستور اطلاعات مربوط به پروتکل مسیریابی OSPF از جمله Router ID همچنین اطلاعات مربوط به انواع Areaهای OSPF را نمایش خواهد داد.Router#show ip ospf
با استفاده از این دستور لیست روترهای همسایه و همچنین نحوه برقراری رابطه مجاورت با آنها نمایش داده می شود پروتکل OSPF روترهای همسایه را در جدول Neighbors Table نگهداری می کند.Router#show ip ospf neighbors
با استفاده از این دستور اطلاعات موجود در جدول Neighbors Table که شامل لیست روترهای همسایه می باشد با جزئیات بیشتری نمایش داده خواهد شد.Router#show ip ospf neighbor detail
با استفاده از این دستور  فقط مسیرهای که به وسیله پروتکل مسیریابی OSPF در جدول مسیریابی روتر ایجاد شده اند نمایش داده خواهد شد.Router#show ip route ospf
این دستور اطلاعات مربوط به اینترفیس های که پروتکل مسیریابی OSPF بر روی آنها فعال می باشد و اینکه هر اینترفیس در چه Areaی قرار دارد را نمایش خواهد داد.Router#show ip ospf interface
این دستور اطلاعات مربوط پروتکل مسیریابی OSPF بر روی اینترفیس serial2/0 و اینکه این اینترفیس در چه Areaی قرار داردرا نمایش خواهد داد.Router#show ip ospf interfaceserial2/0
این دستور اطلاعات موجود در جدول Routing Table یا همان جدول مسیریابی روتر را نمایش می دهد.Router#show ip route
این دستور باعث نمایش خلاصه ای از جدول database مربوط به پروتکل مسیریابی OSPF خواهد شد.Router#show ip ospf database summary
این دستور باعث نمایش اطلاعات جدول database مربوط به پروتکل مسیریابی OSPF خواهد شد.Router#show ip ospf database

مرحله 4: استفاده از دستورات Debug برای عیب یابی پروتکل مسیریابی OSPF

استفاده از دستور Debug باعث خواهد شد اعمال پشت پرده کار پروتکل مسیریابی OSPF نمایش داده شود. با بررسی خروجی دستور Debug می توانید مشکلات مربوط به پروتکل مسیریابی OSPF را تشخیص و برطرف نمایید.

دستورات پروتکل مسیریابی OSPF را در جدول زیر مشاهده می کنید.

تشریح CommandCommand
این دستور عملکرد و وقایع مربوط به پیام های Hello را نمایش خواهد داد.Router#debug ip ospf hello
این دستورعملکرد مربوط کلیه وقایع پروتکل مسیریابی OSPF را نمایش خواهد داد.Router#debug ip ospf events
این دستور عملکرد مربوط ایجاد LSAها را نمایش خواهد داد.Router#debug ip ospf lsa-generation
این دستور عملکرد و وقایع مربوط به برقراری رابطه مجاورت بین روترها را نمایش خواهد داد.Router#debug ip ospf adjacencies
این دستور عملکرد و وقایع مربوط به کلیه OSPF Packetها را نمایش خواهد داد.Router#debug ip ospf packet
این دستور باعث غیر فعال کردن کلیه پردازش های فعال مربوط به debug بر روی Router می شود.Router#no debug all

مقاله مرتبط :

پیکربندی پروتکل مسیریابی OSPF V3 در IPV6

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0