پیکربندی پروتکل مسیریابی EIGRP در IPV6

هدف از این کار پیکربندی پروتکل مسیریابی EIGRP در IPV6 می باشد. تجهیزات مورد نیاز برای انجام این کار 2 عدد روتر سیسکو، 2 عدد سوئیچ سیسکو مدل 2960 سیسکو و 2 عدد PC می باشد.

وضعیت اتصال پورت های Router1:

 

 

 

وضعیت اتصال پورت های روتر2

BandwidthIP AddressConnectedRouter2
100 MbpsFCC:192:168:2::1/64Switch2FastEthernet 0/0
256 KbpsFCC:192:168:10::2/126Router1Serial 0/0/0

وضعیت اتصال پورت های سوئیچ 1

CableConnectedSwitch1
UTP Cat 6Router1FastEthernet 0/1
UTP Cat 6PC1FastEthernet 0/2

وضعیت اتصال روتر های سوئیچ 2

CableConnectedSwitch1
UTP Cat 6Router2FastEthernet 0/1
UTP Cat 6PC2FastEthernet 0/2

تنظیمات کامپیوتر PC1

Default GatewayIP AddressOSComputer Name
FC00:192:168:1::1FCC:192:168:2::2/64Windows 8.1PC1

تنظیمات کامپیوتر PC2

Default GatewayIP AddressOSComputer Name
FC00:192:168:2::1FCC:192:168:2::2/64Windows 8.1PC2

پروتکل مسیریابی EIGRP یک پروتکل اختصاصی شرکت سیسکو می باشد که در IOS های جدید شرکت سیسکو پروتکل EIGRP از IPver6 پشتیبانی می کنند.

پروتکل مسیریابی EIGRP یک پروتکل Advanced Distance Vector می باشد که برای محاسبه Metric از روش ترکیبی استفاده خواهد کرد. پروتکل مسیریابی EIGRP در محیط IPver 6 برای Update جدول مسیریابی از آدرس FF02::10 استفاده می کند.

پروتکل مسیریابی EIGRP در محیط IPver6 بسیار سریعتر از پروتکل مسیریابی EIGRP در محیط IP ver4 اطلاعات مربوط مسیریابی را به روترهای همسایه ارسال خواهد کرد. در پروتکل مسیریابی EIGRP در محیط IPver6 به صورت پیش فرض توانمندی Auto Summarization بر روی کلاس های استاندارد و غیر فعال می باشد.

 

مرحله 1: اتصال به روتر 1

در این مرحله ابتدا توسط نرم افزار Putty به روتر 1 متصل شوید و وارد مد User Mode شوید.

در صورتی که در خط فرمان عبارت زیر را مشاهده می کنید به درستی وارد User Mode شده اید در غیر این صورت اتصال روتر به PC توسط کابل کنسول را بررسی کنید.

Router>

مرحله 2: پیکربندی روتر1 و تنظیم IP Address بر روی اینترفیس های روتر

قبل از پیکربندی IPver6 روی اینترفیس روتر باید IPver6 را بر روی روتر فعال نمایید. به صورت پیش فرض IP ver6 بر روی روتر غیرفعال می باشد.

Router1(config)#ip6 unicast-routing

پیکربندی IPver6 بر روی اینترفیس FastEthernet 0/0

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ipv6 address fc00:192:168:1::1/64

Router1(config-if)#no shut down

Router1(config-if)#exit

پیکربندی IPver6 بر روی اینترفیس Serial 0/0/0

Router1(config)#interface Serial 0/0/0

Router1(config-if)#ipv6 address fc00:192:168:1::1/126

Router1(config-if)#clock rate 64000

Router1(config-if)#no shut down

Router1(config-if)#exit

مرحله 3: پیکربندی روتر 2 و تنظیم IP Address بر روی اینترفیس های روتر

قبل از پیکربندی IPver6 روی اینترفیس روتر باید IP ver6 را بر روی روتر فعال نمایید. به صورت پیش فرض IP ver6 بر روتر غیرفعال می باشد.

برای فعال نمودن IPver6 بر روی روتر 2 از دستور زیر استفاده نمایید.

Router2(config)#ipv6 unicast-routing

پیکربندی IPver6 بر روی اینترفیس FastEthernet 0/0

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ipv6 address fc00:192:168:1::1/64

Router2(config-if)#no shut down

Router2(config-if)#exit

پیکربندی IPver6 بر روی اینترفیس Serial 0/0/0

Router2(config)#interface Serial 0/0/0

Router2(config-if)#ipv6 address fc00:192:168:1::2/126

Router2(config-if)#no shut down

Router2(config-if)#exit

مرحله 4: پیکربندی پروتکل مسیریابی EIGRP بر روی روتر1

پیکربندی پروتکل مسیریابی EIGRP در IPV6 دارای مراحلی به شرح زیر می باشد:

ـ فعال کردن توانمندی IPver6 با دستور IPv6 unicast-Routing بر روی روتر

ـ فعال کردن پروتکل مسیریابی EIGRP با یک شماره AS و ورود به مد پیکربندی EIGRP

ـ فعال نمودن پروتکل مسیریابی EIGRP برای IPver6 با دستور no Shutdown در مد پیکربندی EIGRP

ـ پیکربندی Router ID در صورت نیاز

ـ فعال نمودن پروتکل EIGRP در مد اینترفیس های روتر

ـ در این مرحله پروتکل مسیریابی EIGRP بر روی روتر1 پیکربندی خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#ipv6 router eigrp 10

Router1(config-rtr)#no shutdown

Router1(config-rtr-id 1.1.1.1

تشریح CommandCommand
این دستور باعث فعال شدن EIGRP روی روتر و تعیین شماره 10 به عنوان شماره AS بر روی روتر خواهد شد.Router1(config)#ipv6 router eigrp 10
این دستور باعث فعال شدن پروتکل مسیریابی EIGRP برای IP ver6 خواهد شد.Router1(config-rtr)#no shutdown
این دستور باعث تعیین آدرس 1.1.1.1 به عنوان Router ID برای روتر1 خواهد شد.Router1(config-rtr)#router-id 1.1.1.1
در انتخاب Router ID به موارد زیر توجه کنید:
در صورتی که هیچ اینترفیسی دارای Ipver4 بر روی روتر وجود نداشته باشد باید در مد پیکربندی EIGRP برای روتر به صورت دستی Router ID تعیین شود.
در صورتی که بر روی روتر اینترفیس Loopback با آدرس IP ver4 وجود داشته باشد آدرس Loopback اینترفیس به عنوان Router ID انتخاب خواهد شد.
در صورتی که بر روی روتر اینترفیس فیزیکی با IP ver4 وجود داشته باشد بزرگترین IP Address Ver4 به عنوان Router ID انتخاب خواهد شد.
نکته : بر روی روتر1 هیچ اینترفیس Loopback و اینترفیس فیزیکی با IP ver4 پیکربندی نشده است بنابراین در پیکربندی پروتکل EIGRP برای IP ver6 به صورت دستی Router ID تعیین خواهد شد.

در مرحله بعد پروتکل مسیریابی EIGRP بر روی اینترفیس های روتر1 تعریف خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#interfacefastethernet 0/0

Router1(config-if)#ipv6 eigrp 10

دستور بالا باعث فعال شدن پروتکل مسیریابی EIGRP با AS شماره 10 بر روی اینترفیس FastEthernet 0/0 خواهد شد.

Router1(config)#interface serial 0/0/0

Router1(config-if)#ipv6 eigrp 10

دستور بالا باعث فعال شدن پروتکل مسیریابی EIGRP با AS شماره 10 بر روی اینترفیس Serial 0/0/0 خواهد شد.

 

مرحله 5: پیکربندی پروتکل مسیریابی EIGRP بر روی روتر2

در این مرحله پروتکل مسیریابی EIGRP بر روی روتر2 پیکربندی خواهد شد. برای این منظور از دستور زیر استفاده نمایید.

Router2(config)#ipv6 roter eigrp 10

Router2(config-rtr)#no shutdown

Router2(config-rtr)#router-id 2.2.2.2

تشریح CommandCommand
این دستور باعث فعال شدن EIGRP روی روتر و تعیین شماره 10 به عنوان شماره AS بر روی روتر خواهد شد.Router1(config)#ipv6 router eigrp 10
این دستور باعث فعال شدن پروتکل مسیریابی EIGRP برای IP ver6 خواهد شد.Router1(config-rtr)#no shutdown
این دستور باعث تعیین آدرس 2.2.2.2 به عنوان Router ID برای روتر2 خواهد شد.Router1(config-rtr)#router-id 2.2.2.2
در انتخاب Router ID به موارد زیر توجه کنید:
در صورتی که هیچ اینترفیسی دارای Ipver4 بر روی روتر وجود نداشته باشد باید در مد پیکربندی EIGRP برای روتر به صورت دستی Router ID تعیین شود.
در صورتی که بر روی روتر اینترفیس Loopback با آدرس IP ver4 وجود داشته باشد آدرس Loopback اینترفیس به عنوان Router ID انتخاب خواهد شد.
در صورتی که بر روی روتر اینترفیس فیزیکی با IP ver4 وجود داشته باشد بزرگترین IP Address Ver4 به عنوان Router ID انتخاب خواهد شد.
نکته : بر روی روتر1 هیچ اینترفیس Loopback و اینترفیس فیزیکی با IP ver4 پیکربندی نشده است بنابراین در پیکربندی پروتکل EIGRP برای IP ver6 به صورت دستی Router ID تعیین خواهد شد.

در مرحله بعد پروتکل EIGRP بر روی اینترفیس های روتر2 تعریف خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router2(config)#interface fastEthert 0/0

Router2(config-if)#ipv6 eigrp 10

دستور بالا باعث فعال شدن پروتکل مسیریابی EIGRP با AS شماره 10 بر روی اینترفیس FastEthernet خواهد شد.

Router2(config)#interface serl 0/0/0

Router2(config-if)ipv6 eigrp 10

دستور بالا باعث فعال شدن پروتکل مسیریابی EIGRP با AS شماره 10 بر روی اینترفیس Serial 0/0/0 خواهد شد.

بعد از تعریف پروتکل مسیریابی EIGRP بر روی روتر1 و روتر2 جدول مسیریابی روتر1 را مشاهده نمایید.

IPv6 Routing Table – 6 entries

C FC00:192:168:1:: /64[0/0]

Via::,FastEthernet0/0

L FC00:192:168:1::1/128[0/0]

Via::,FastEthernet0/0

D FC00:192:168:2:: /64[90/2172416 ]

viaFE80::20C:CFFF:FF8A:BE01,Serial0/0/0

C FC00:192:168:10::/126[0/0]

Via::, Serial0/0/0

L FC00:192:168:10::1/128[0/0]

Via::,Serial0/0/0

FF00::/8[0/0]

Via::, Null0

به خروجی دستور Show IPV6 route و قسمت های مشخص شده در این خروجی توجه نمایید.

 

مرحله 6: تست ارتباطی بین کامپیوتر 1 و 2

در این مرحله ارتباط بین PC1 و PC2 را  بررسی خواهیم کرد برای این منظور از دستور Ping بر روی Pc1 استفاده نمایید.

PC1/>ping fc00:192:168:2::with 32 bytes of data:

Reply from fc00:192:168:2::2 time<1ms

Reply from fc00:192:168:2::2 time<1ms

Reply from fc00:192:168:2::2 time<1ms

Reply from fc00:192:168:2::2 time<1ms

همانطور که مشاهده می کنید نتیجه این تست موفقیت آمیز بود و بین PC1 و PC2 ارتباط برقرار می باشد.

مقاله مرتبط :

پیکربندی Static Route در IP Ver6

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0