پیکربندی پروتکل مسیریابی RIP در IPV6

هدف از انجام این کار پیکربندی پروتکل مسیریابی RIPng می باشد.

تجهیزات مورد نیاز برای پیکربندی پروتکل مسیریابی RIP در IPV6 2 عدد روتر سیسکو ، 2 عدد سوئیچ سیسکو مدل 2960 سیسکو، 2 عدد PC می باشد.

وضعیت اتصال پورت های روتر1

BandwidthIP AddressConnectedRouter1
100 MbpsFCC:192:168:2::1/64Switch1FastEthernet 0/0
256 KbpsFCC:192:168:2::1/126Router2Serial 0/0/0

 وضعیت اتصال پورت های روتر2

BandwidthIP AddressConnectedRouter2
100 MbpsFCC:192:168:2::1/64Switch2FastEthernet 0/0
256 KbpsFCC:192:168:2::1/126Router1Serial 0/0/0

وضعیت اتصال پورت های سوئیچ 1

CableConnectedSwitch1
UTP Cat 6Router1FastEthernet 0/1
UTP Cat 6PC1FastEthernet 0/2

وضعیت پورت های سوئیچ 2

CableConnectedSwitch1
UTP Cat 6Router2FastEthernet 0/1
UTP Cat 6PC2FastEthernet 0/2

تنظیمات کامپیوتر PC1

Default GatewayIP AddressOSComputer Name
FC00:192:168:1::1FCC:192:168:2::2/64Windows 8PC1

تنظیمات کامپیوتر PC2

Default GatewayIP AddressOSComputer Name
FC00:192:168:2::1FCC:192:168:2::2/64Windows 8PC2

RIP یکی از پروتکل های مسیریابی قدیمی می باشد که ابتدا نسخه 1 آن و بعدها نسخه 2 آن تولید شد. پروتکل مسیریابی RIP یک پروتکل استاندارد باز می باشد و توسط تولید کنندگان تجهیزات لایه 3 از جمله شرکت سیسکو پشتیبانی می شود.

به علت اینکه RIP ver 1 و RIP ver2 برای کار در محیط  IP ver4 طراحی شده بودند با گسترش IP ver6 یک نسخه جدید از RIP با نام RIPng که برگفته از عبارت RIP Next generation می باشد برای کار در محیط IP ver6 طراحی شد.

مرحله 1: اتصال به روتر 1

در این مرحله ابتدا توسط نرم افزار Putty به روتر1  متصل شوید و وارد مد User Mode شوید.

در خط فرمان چه چیزی را مشاهده می کنید؟

در صورتی کهدر خط فرمان عبارت زیر را مشاهده می کنید به درستی وارد User Mode شده اید در غیر این صورت اتصال روتر به PC توسط کابل کنسول را بررسی کنید.

Router>

مرحله 2: پیکربندی روتر1 و   تنظیم IP Address بر روی اینترفیس های روتر

قبل از  پیکربندی IPver 6 روی اینترفیس روتر باید IPver6 را بر روی روتر فعال نمایید. به صورت پیش فرض IP ver6 بر روی روتر غیرفعال می باشد.

Router1(config)#ipv6 unicast-routing

پیکربندی IP ver6 بر روی اینترفیس FastEthernet 0/0

Router1(config)#ipv6 fastEthernet 0/0

Router1(config-if)#ipv6 address fc00:192:168:1::1/64

Router1(config-if)#no shutdown

Router1(config-if)#exit

پیکربندی IP ver6 بر روی اینترفیس Serial 0/0/0

Router1(config)#interface serial 0/0/0

Router1(config-if)#ipv6 address fc00:192:168:10::1/126

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

Router1(config-if)#exit

مرحله 3: پیکربندی روتر 2 و تنظیم  IP Address بر روی اینترفیس های روتر

قبل از پیکربندی IPver6 روی اینترفیس روتر باید IPver6 را بر روی روتر فعال نمایید. به صورت پیش فرض IPver6 بر روی روی روتر غیر فعال می باشد.

برای فعال نمودن IPver6 بر روی روتر2 از دستور زیر استفاده نمایید.

Router2(config)#ipv6 unicast-routing

پیکربندی IPver6 بر روی اینترفیس FastEthernet 0/0

Router2(config)#interface FastEthernet 0/0

Router2(config-if)#ipv6 address fc00:192:168:2::1/64

Router2(config-if)#no shutdown

Router2(config-if)#exit

پیکربندی IP ver6 بر روی اینترفیس Serial 0/0/0

Router2(config)#interface Serial 0/0/0

Router2(config-if)#ipv6 address fc00:192:168:10::2/126

Router2(config-if)#no shutdown

Router2(config-if)#exit

 

مرحله 4: پیکربندی RIPng بر روی روتر1

در این مرحله پروتکل مسیریابی RIPng بر روی روتر 1 پیکربندی خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#ipv6 router rip 10

Router1(config-rtr)#

تشریح CommandCommand
فعال کردن پروتکل RIPng روی روتر و تعیین شماره 10 به عنوان Process ID که از این عدد برای شناسایی Process مربوط به RIP بر روی روتر خواهد شد.Router2(config)#ipv6 router rip 10
نکته: نیازی به یکسان بودن شماره Process ID در روتر های مختلف نمی باشد.

در مرحله بعد پروتکل RIPng بر روی اینترفیس های روتر 1 تعریف خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ipv6 rip 10 enable

دستور بالا باعث فعال شدن پروتکل مسیریابی RIPng با Process ID شماره 10 بر روی اینترفیس FastEthernet خواهد شد.

Router1(config)#interface serial 0/0/0

Router1(config-if)#ipv6 rip 10 enable

دستور بالا باعث فعال شدن پروتکل مسیریابی RIPngبا Process ID شماره 10 بر روی اینترفیس Serial 0/0/0 خواهد شد.

 

مرحله 5: پیکربندی RIPng بر روی روتر 2

در این مرحله پروتکل مسیریابی RIPng بر روی روتر 2 پیکربندی خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router2(config)ipv6 router rip 10

Router2(config-rtr)#

تشریح CommandCommand
فعال کردن پروتکل RIPng روی روتر و تعیین شماره 10 به عنوان Process ID که از این عدد برای شناسایی Process مربوط به RIP بر روی روتر خواهد شد.
نکته: نیازی به یکسان بودن شماره Process ID در روتر های مختلف نمی باشد.
Router2(config)#ipv6 router rip 10

در مرحله بعد پروتکل RIPng بر روی اینترفیس های روتر 2 تعریف خواهد شد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#interface fastEthernet 0/0/0

Router1(config-if)#ipv6 rip 10 enable

دستور بالا باعث فعال شدن پروتکل مسیریابی RIPng با Process ID شماره 10 بر روی اینترفیس FastEthernet 0/0 خواهد شد.

Router1(config)#interface Serial 0/0/0

Router1(config-if)#ipv6 rip 10 enable

دستور بالا باعث فعال شدن پروتکل مسیریابی RIPng با Process ID شماره 10 بر روی اینترفیس Serial 0/0/0 خواهد شد.

بعد از تعریف پروتکل مسیریابی RIPng بر روی روتر 1 و روتر2 جدول مسیریابی رووتر 1 را مشاهده نمایید.

Router1#show ipv6 route

IPv6 Routing Table – 6 entries

C FC00:192:168:1::1/128[0/0]

Via::,FastEthernet0/0

L FC00:192:168:1::1/128[0/0]

viaFE80::20C:CFFF:FF8A:BE0001,Serial0/0/0

C FC00:192:168:10::/126[0/0]

Via::, Serial0/0/0

L FC00:192:168:10::1/128[0/0]

Via::,Serial0/0/0

L FF::/8[0/0]

Via::, Null0

به خروجی دستور show ipv6 route و قسمت های مشخص شده در این خروجی توجه نمایید.

مرحله 6: تست ارتباطی بین کامپیوتر PC1 و PC2

در این مرحله ارتباط بین PC1 و PC2 تست خواهیم کرد برای این منظور از دستور Ping بر روی PC1 استفاده خواهد شد.

PC1\>ping fc00:192:168:2::2

Pinging fc00:192:168:2::2 with 32 bytes of data:

Reply from fc00:192:168:2::2 time,1ms

Reply from fc00:192:168:2::2 time,1ms

Reply from fc00:192:168:2::2 time,1ms

Reply from fc00:192:168:2::2 time,1ms

همان طور که مشاهده می کنید نتیجه این تست موفقیت آمیز بود و بین PC1 و PC2 ارتباط برقرار می باشد.

سایر مقالات :

معرفی و پیکربندی IPVer6 بر روی Router

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0