پیکربندی پروتکل مسیریابی OSPF-قسمت دوم

پیکربندی پروتکل مسیریابی OSPF

انوع پیام در پروتکل OSPF

پروتکل OSPF برای بروزرسانی و Update جدول مسیریابی از 5 نوع پیام به شرح زیر استفاده خواهد کرد:

پیکربندی پروتکل مسیریابی OSPF

 

 شما می توانید برای مشاهده‌ی پیکربندی پروتکل مسیریابی OSPF-قسمت اول به لینک قرارداده شده مراجعه نمایید.

 

مرحله ی1: پیکربندی تنظیمات IP Address بر روی Router1 و Router2 و Router3:

پیکربندی اینترفیس FastEthernet0/0 روتر Router1 :

Router1#config t

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ip address 192.168.2.1 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router1 :

Router1(config)#interface serial 2/0

Router1(config-if)#ip address 192.168.0.1 255.255.255.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet0/0 روتر Router2 :

Router2#config t

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ip address 192.168.3.1 255.255.255.0

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router2 :

Router2(config)#interface serial 2/0

Router2(config-if)#ip address 192.168.0.2 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial3/0 روتر Router2 :

Router2(config)#interface serial 3/0

Router2(config-if)#ip address 192.168.1.1 255.255.255.0

Router2(config-if)#clock rate 64000

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet0/0 روتر Router3 :

Router3#config t

Router3(config)#interface fastEthernet 0/0

Router3(config-if)#ip address 192.168.4.1 255.255.255.0

Router3(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router3 :

Router3(config)#interface serial 2/0

Router3(config-if)#ip address 192.168.1.2 255.255.255.0

Router3(config-if)#no shutdown

 

مرحله 2: پیکربندی OSPF بر روی Router1 در محیط Single Area:

در این مرحله پروتکل مسیریابی OSPF را در محیط Single Area پیکربندی خواهیم نمود توجه داشته باشید که در این مقاله کلیه Routerهای ما در Area 0 یا همان Single Area قراردارند.

در پیکربندی OSPF شما باید شبکه های که مستقیم به اینترفیس های Router1 متصل می باشند یا به عبارتی شبکه های که در داخل جدول مسیریابی Router1 به عنوان شبکه های connented شناسایی و تشخیص داده می شوند و در Routing mode در مقابل دستور Network در پیکربندی پروتکل مسیریابی OSPF وارد نمایید و بعد از مشخص کردن شبکه ها باید Wildcard Mask آن شبکه و Areaی که هر شبکه در آن قرار دارد مشخص شود همان طور که در دستورات زیر مشاهده می کنید.

Router1#config t

Router1(config)#router ospf 10

Router1(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router1(config-router)#network 192.168.2.0  0.0.0.255 area 0

Router1(config-router)#no shutdown

پیکربندی پروتکل مسیریابی OSPF

 

با استفاده از دستور زیر پیکربندی های انجام شده بر روی Router1 به صورت همیشگی در حافظه NVRAM روتر کپی خواهد شد.

Router1#copy running-config startup-config

 

مرحله 3: پیکربندی OSPF بر روی Router2 در محیط Single Area:

در این مرحله پروتکل مسیریابی OSPF را در محیط Single Area پیکربندی خواهیم نمود توجه داشته باشید که در این مقاله کلیه Routerهای ما در Area 0 یا همان Backbone Area قراردارند.

در پیکربندی OSPF شما باید شبکه های که مستقیم به اینترفیس های Router2 متصل می باشند یا به عبارتی شبکه های که در داخل جدول مسیریابی Router2 به عنوان شبکه های connented شناسایی و تشخیص داده می شوند و در Routing mode در مقابل دستور Network در پیکربندی پروتکل مسیریابی OSPF وارد نمایید و بعد از مشخص کردن شبکه ها باید Wildcard Mask آن شبکه و Areaی که هر شبکه در آن قرار دارد مشخص شود همان طور که در دستورات زیر مشاهده می کنید.

Router2#config t

Router2(config)#router ospf 10

Router2(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.3.0  0.0.0.255 area 0

Router2(config-router)#exit

 

پیکربندی پروتکل مسیریابی OSPF

با استفاده از دستور زیر پیکربندی های انجام شده بر روی Router2 به صورت همیشگی در حافظه NVRAM روتر کپی خواهد شد.

Router2#copy running-config startup-config

 

مرحله 4: پیکربندی OSPF بر روی Router3 در محیط Single Area:

در این مرحله پروتکل مسیریابی OSPF را در محیط Single Area پیکربندی خواهیم نمود توجه داشته باشید که در این مقاله کلیه Routerهای ما در Area 0 یا همان Backbone Area قراردارند.

در پیکربندی OSPF شما باید شبکه های که مستقیم به اینترفیس های Router3 متصل می باشند یا به عبارتی شبکه های که در داخل جدول مسیریابی Router3 به عنوان شبکه های connented شناسایی و تشخیص داده می شوند و در Routing mode در مقابل دستور Network در پیکربندی پروتکل مسیریابی OSPF وارد نمایید و بعد از مشخص کردن شبکه ها باید Wildcard Mask آن شبکه و Areaی که هر شبکه در آن قرار دارد مشخص شود همان طور که در دستورات زیر مشاهده می کنید.

Router3#config t

Router3(config)#router ospf 10

Router3(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router3(config-router)#network 192.168.4.0  0.0.0.255 area 0

Router3(config-router)#exit

پیکربندی پروتکل مسیریابی OSPF

 

با استفاده از دستور زیر پیکربندی های انجام شده بر روی Router3 به صورت همیشگی در حافظه NVRAM روتر کپی خواهد شد.

Router3#copy running-config startup-config

 

مرحله 5: مشاهده جدول Routing table روترها:

دستور show ip route را بر روی Router1 اجرا کنید و با دقت به خروجی آن توجه کنید.

Router1#show ip route

Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, Serial2/0

O 192.168.1.0/24 [110/2343] via 192.168.0.2,00:01:35,Serial2/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 [110/1563] via 192.168.0.2,00:01:55,Serial2/0

O 192.168.4.0/24 [110/2343] via 192.168.0.2,00:02:10,Serial2/0

به خروجی دستور show ip route در بالا با دقت توجه کنید چرا در مقابل بعضی از مسیرها کاراکتر O وجود دارد؟

دستور show ip route را بر روی Router2 اجرا کنید و با دقت به خروجی آن توجه نمایید.

 

Router2#show ip route

Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, Serial2/0

C 192.168.1.0/24 is directly connected, Serial3/0

O 192.168.2.0/24 [110/782] via 192.168.0.1,00:10:02,Serial2/0

C 192.168.3.0/24 is directly connected, FastEthernet0/0

O 192.168.4.0/24 [110/782] via 192.168.1.2,00:09:41,Serial3/0

 

دستور show ip route را بر روی Router3 اجرا کنید و با دقت به خروجی آن توجه نمایید.

 

Router3#show ip route

Gateway of last resort is not set

O 192.168.0.0/24 [110/1562] via 192.168.1.1, 00:11:29, Serial2/0

C 192.168.1.0/24 is directly connected, Serial2/0

O 192.168.2.0/24 [110/1563] via 192.168.1.1, 00:11:14, Serial2/0

O 192.168.3.0/24 [110/782] via 192.168.1.1, 00:11:14, Serial2/0

C 192.168.4.0/24 is directly connected, FastEthernet0/0

 

مرحله 6 : تست نمودن ارتباط بین کامپیوترها با دستور Ping:

در این مرحله توسط PC1 کامپیوتر PC2 را Ping خواهیم کرد.

PC1>ping 192.168.3.2

Pinging 192.168.3.2 with 32 bytes of data:

Reply from 192.168.3.2: bytes=32 time=20ms TTL=254

Reply from 192.168.3.2: bytes=32 time=20ms TTL=254

Reply from 192.168.3.2: bytes=32 time=20ms TTL=254

Reply from 192.168.3.2: bytes=32 time=20ms TTL=254

 

در این مرحله توسط PC1 کامپیوتر PC5 را Ping خواهیم کرد.

PC1>ping 192.168.4.2

Pinging 192.168.4.2 with 32 bytes of data:

Reply from 192.168.4.2: bytes=32 time=20ms TTL=254

Reply from 192.168.4.2: bytes=32 time=20ms TTL=254

Reply from 192.168.4.2: bytes=32 time=20ms TTL=254

Reply from 192.168.4.2: bytes=32 time=20ms TTL=254

مرحله 7 : پیکربندی های Passive Interface برای پروتکل OSPF:

به تصویر زیرتوجه کنید در این تصویر نیازی به ارسال پیام های Hello و برقراری رابطه مجاورت از طریق برخی از اینترفیس ها نمی باشد به علت اینکه این اینترفیس ها به یک روتر اتصال ندارند.ارسال مرتب اطلاعات و تلاش برای برقراری رابطه مجاورت از طریق اینترفیس ها باعث اشغال پهنای باند لینک و همچنین افزایش بار پردازشی  CPU روتر خواهد شد با غیرفعال کردن ارسال پیام های OSPF بر روی برخی از اینترفیس ها علاوه بر افزایش کارایی امنیت نیز افزایش می یابد.

جهت پیکربندی Passive Interface بر روی Router1 از دستور زیر استفاده نمایید.

Router1(config)#router ospf 10

Router1(config-router)#passive-interface fastethernet 0/0

جهت پیکربندی Passive Interface بر روی Router2 از دستور زیر استفاده نمایید.

Router2(config)#router ospf 10

Router2(config-router)#passive-interface fastethernet 0/0

 

جهت پیکربندی Passive Interface بر روی Router3 از دستور زیر استفاده نمایید.

Router3(config)#router ospf 10

Router3(config-router)#passive-interface fastethernet 0/0

 

مرحله 8 : پیکربندی OSPF Timer:

در پروتکل مسیریابی OSPF زمان مربوط به ارسال پیام های Hello و زمان مربوط به dead-interval بر روی اینترفیس های که پروتکل OSPF بر روی آنها فعال شده است قابل تنظیم می باشد برای این منظور از دستور زیر استفاده نمایید.

Router1(config)#interface serial 2/0

Router1(config-if)#ip ospf hello-interval 10

Router1(config-if)#ip ospf dead-interval 30

 

پیکربندی پروتکل مسیریابی OSPF

 

 

نکته: hello-interval و dead-interval باید بین دو عدد Router همسایه که قصد برقراری رابطه مجاورت را خواهند داشت یکسان تعیین شود و پیشنهاد می شود که مقدار dead-interval سه برابر مقدار hello-interval تعیین شود.

پیشنهاد می کنیم بسته به سرعت لینک ارتباطی مقدار hello interval و dead interval را تعیین کنید.

 

مرحله 9 : پیکربندی های Router ID در پروتکل مسیریابی OSPF:

در پروتکل مسیریابی OSPF برای شناسایی Routerها از یک عدد 32 bit با فرمت IP Address به نام RID که بر گرفته از عبارت Router ID می باشد استفاده خواهد شد.

Router ID برای هر Router در داخل حوزه OSPF یکتا وو منحصر به فرد می باشد بسیاری از عملکردهای پروتکل مسیریابی OSPF وابسته به Router ID می باشد یکی از کاربردهای Router ID تعیین Router اختصاصی به نام Designated Router(DR) و Backup Designated Router(BDR) در شبکه های Broadcast می باشد در این شبکه ها Router ی که بالاترین Router ID را داشته باشد به نام DR و Routerی که بعد از DR بالاترین Router ID را دارد به عنوان BDR انتخاب خواهد شد.

به صورت پیش فرض بالاترین IP Address مربوط به اینترفیس فیزیکی Router به عنوان Router ID تعیین خواهد شد.

به مثال زیر توجه کنید که روتر دارای سه عدد اینترفیس فیزیکی می باشد همان طور که در تصویر زیر مشاهده می کنید در این حا آدرس 192.168.2.200 به عنوان Router ID انتخاب خواهد شد.

پیکربندی پروتکل مسیریابی OSPF

 

در صورتی که بر روی روتر اینترفیس Loopback تعریف شود IP Address مربوط  به اینترفیس Loopback به عنوان Router ID تعیین خواهد شد حتی اگر IP Address مربوط به اینترفیس های فیزیکی از IP Address اینترفیس Loopback بزرگتر باشد.

برای تعیین اینترفیس به صورت Loopback بر روی Router از دستور زیر استفاده نمایید.

Router (config)#interface Loopback 0

Router (config-if)#ip address 1.1.1.1 255.255.255.255

شما قادر خواهید بود به صورت دستی Router ID مربوط به یک Router را تعیین نمایید.

 

برای تعیین Router ID به صورت دستی در مد پیکربندی OSPF از دستور زیر استفاده کنید.

Router (config)#router ospf 10

Router (config- router)# router-id 100.100.100.100

در مثال بالا مقدار 100.100.100.100 به عنوان Router ID تعیین خواهد شد.

نکته: در صورت تعیین اینترفیس Loopback با تعیین Router ID به صورت دستی برای اعمال تغییرات و تغییر Router ID بر روی روتر از دستور زیر استفاده کنید یا روتر را Reload نمایید.

 

Router#clear ip ospf process

جهت مشاهده Router ID بر روی یک Router از دستور زیر استفاده نمایید.

Router#show ip ospf

Routing process”ospf10”with ID 100.100.100.100

Supports only single TOS(TOS0)routes

به خروجی دستور بالا توجه نمایید همان طور که مشاهده می کنید Router ID مربوط به Router برابر با 100.100.100.100 خواهد بود.

 

مرحله 10 : پیکربندی های Authentication پروتکل مسیریابی OSPF:

در پروتکل مسیریابی OSPF می تواندی احراز هویت یا Authentication را فعال کنید در این حالت روترهای که دارای رمز (Password) مشترک می باشند قادر به برقراری رابطه مجاورت و تبادل اطلاعات مسیریابی می باشند.

در صورت فعال کردن احراز هویت Authentication در پروتکل مسیریابی OSPF در صورتی که یک روتر بیگانه یا یک هکر که کامپیوتر خود را به عنوان یک روتر OSPF معرفی خواهد کرد و قصد دارد با تبلیغ شبکه های جعلی و غیرواقعی مسیر عبور بسته ها را به سمت خود هدایت یا در پروسه مسیریابی OSPF اختلال ایجاد کنند توانایی انجام این کار نخواهند داشت.

پروتکل مسیریابی OSPF از دو روش برای احرازهویت به شرح زیر استفاده خواهد کرد:

Simple Authentication

MD5 Authentication

Simple Authentication: در ایم روش Password یا کلمه رمز به صورت متن ساده بدون اینکه رمزگذاری شود بین Routerها رد و بدل خواهد شد در این حالت یک هکر با شکار بسته های Hello مربوط به پروتکل مسیریابی OSPF و بررسی اطلاعات داخل این بسته توانایی دسترسی به کلمه رمز Simple Authenticationرا خواهد داشت.

MD5 Authentication:در این روش Password یا کلمه رمز به صورت متن ساده بین Routerها رد و بدل نخواهد شد. در این روش کلمه رمز با استفاده از پروتکل MD5 به صورت hash شده بین روترها مبادله خواهد شد که امنیت بالاتری نسبت به روش Simple Authentication خواهد داشت.

 

پیکربندی OSPF Simple Authentication:

در این مرحله می خواهیم Simple Authentication را بر روی Router1،Router2 و Router3 پیکربندی کنیم .

پیکربندی های مربوط به Router1 را در پنجره زیر با دقت مشاهده و بررسی کنید.

 

پیکربندی پروتکل مسیریابی OSPF

 

پیکربندی های مربوط به Router2 را در پنجره زیر با دقت مشاهده و بررسی کنید:

 

پیکربندی پروتکل مسیریابی OSPF

 

 

پیکربندی های مربوط به Router3 را در پنجره زیر با دقت مشاهده و بررسی کنید:

 

پیکربندی پروتکل مسیریابی OSPF

 

همانطور که مشاهده می کنید در پیکربندی های Router1،Router2 و Router3 یک کلید برای احراز هویت به نام CCNA تعریف شده است که باید در روترهای که می خواهند یکدیگر را احراز هویت نمایند Authentication مشترک باشد.

 

پیکربندی OSPF MD5 Authentication:

در این مرحله می خواهیم MD5 Authentication را بر روی Router1،Router2 و Router3 پیکربندی کنیم.

برای پیکربندی  MD5 Authenticationبر روی Router1 از دستورات زیر استفاده نمایید.

Router1(config)#interface Serial2/0

Router1(config- if)# ip ospf message-digest-key 1 md5 CCNA

Router1(config-if)#exit

Router1(config)#router ospf 10

Router1(config-router)#area 0 authentication message-digest

پیکربندی پروتکل مسیریابی OSPF

 

 

برای پیکربندی MD5 Authentication بر روی Router2 از دستورات زیر استفاده نمایید.

Router2(config)#interface Serial2/0

Router2(config- if)# ip ospf message-digest-key 1 md5 CCNA

Router2(config-if)#exit

Router2(config)#interface Serial3/0

Router2(config- if)# ip ospf message-digest-key 1 md5 CCNA

Router2(config-if)#exit

Router2(config)#router ospf 10

Router2(config-router)#area 0 authentication message-digest

برای پیکربندی MD5 Authentication بر روی Router3 از دستورات زیر استفاده نمایید.

Router3(config)#interface Serial2/0

Router3(config- if)# ip ospf message-digest-key 1 md5 CCNA

Router3(config-if)#exit

Router3(config)#router ospf 10

Router3(config-router)#area 0 authentication message-digest

بعد پیکربندی MD5 Authentication قبل از برقراری رابطه مجاورت و مبادله اطلاعات مسیریابی پروتکل OSPF بین Router1،Router2 و Router3 باید یکدیگر راشناسایی و احراز هویت نمایند.

 

مرحله 11: نحوه محاسبه Metric در پروتکل مسیریابی OSPF:

OSPF Metric

محاسبه Metric برای تعیین بهترین مسیر برای هر مقصد در پروتکل مسیریابی OSPF بر اساس پهنای باند لینک محاسبه خواهد شد واز طریق فرمول زیر محاسبه خواهد شد.

Cost = 100/ (Interface Bandwidth)

 

پیکربندی پروتکل مسیریابی OSPF

 

نکته: اگر توجه داشته باشید ارزش لینک یا همان Link Cost به صورت پیش در اتصال Fast Ethernet و Gigabit Ethernetبرابر می باشد.پروتکل مسیریابی OSPF ارزش این دو اتصال را یکسان فرض خواهد کرد که شما می توانید رفتار OSPF را برای محاسبه متریک اتصالات Fast Ethernet و Gigabit Ethernetتغییر دهید برای این منظور از دستور زیر استفاده نمایید.

Router#config

Router (config)#router ospf 10

Router (config-Router)#auto-cost reference-bandwidth 1000

نکته: این دستور باید بر روی کلیه روترهای سازمانی شما که دارای یک مرز مدیریتی و مسیریابی یکسانی هستند اجرا شود.

 

بعد از اجرای دستور بالا پروتکل مسیریابی OSPF متریک اتصالات Fast Ethernet و Gigabit Ethernet را یکسان فرض نخواهد کرد و حال اتصالات Gigabit Ethernet دارای ارزش 1 و اتصالات Fast Ethernet دارای ارزش 10 و اتصالات Ethernet دارای ارزش 100 خواهند بود و در این حالت Cost بر اساس فرمول زیر محاسبه خواهد شد.

(Cost = 1000/ (Interface Bandwidth

مرحله 12: آشنایی با دستورات پیکربندی پروتکل مسیریابی OSPF:

دستورات پیکربندی پروتکل مسیریابی OSPF را در جدول زیر مشاهده می کنید:

پیکربندی پروتکل مسیریابی OSPF

 

دستورات نمایش و مدیریت عملکرد پروتکل مسیریابی OSPF:

 

پیکربندی پروتکل مسیریابی OSPF

 

دستورات مربوط به پروتکل مسیریابی OSPF که در مد اینترفیس اجرا خواهند شد:

 

پیکربندی پروتکل مسیریابی OSPF

 

دستورات عیب یابی پروتکل مسیریابی OSPF:

 

پیکربندی پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router1 را مشاهده می کنید:

 

پیکربندی پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router2 را مشاهده می کنید:

پیکربندی پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router3 را مشاهده می کنید:

پیکربندی پروتکل مسیریابی OSPF

 

محصولات پیشنهادی: مشاهده‌ی مشخصات روترهای شبکه ، مشخصات سوئیچ های شبکه  .

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0