پیکربندی پروتکل مسیریابی EIGRP (بخش دوم)

محاسبه Metric در پروتکل EIGRP

در مقاله پیکربندی پروتکل مسیریابی EIGRP (بخش اول)  تا حدودی زیادی در رابطه با پروتکل مسیریابی EIGRP توضیح دادیم، حال در این مقاله به بررسی دیگر ویژگی های این پروتکل می پردازیم.در پیکربندی پروتکل مسیریابی EIGRP یکسری پارامترها برای محاسبه Metric به کار می روند به صورت K Value ها مشخص شده اند همان طور که در تصویر زیر مشاهده می کنید هر K Value معادل یک پارامتر می باشد که در محاسبه Metric می تواند در نظر گرفته شود یا خیر که مقدار K Value را در جدول زیر مشاهده می کنید.

پیکربندی پروتکل مسیریابی EIGRP

تنظیم پیش فرض برای محاسبه Metric روی EIGRP Metric به صورت زیر است.

By Default: K1=1, K2=0, K3=1, K4=0, K5=0

همان طور که مشاهده می کنید به صورت پیش فرض از پارامترهای Bandwidth و Delay برای محاسبه Metric در پروتکل مسیریابی EIGRP استفاده می شود.

در داخل پیام های Hello Packet که به صورت متناوب از طریق روتر های سیسکو که بر روی آنها پروتکل مسیریابی EIGRP پیکربندی شده است برای روترهای همسایه ارسال می شود مقادیر مربوط به این K Value ها قرار دارند و در صورتی که مقدار موجود در این Hello پیام ها یکی نباشد دو عدد روتر که پروتکل مسیریابی EIGRP بر روی آنها پیکربندی شده است قادر به برقراری رابطه مجاورت به صورت صحیح نی باشند.

فرمول محاسبه Metric در پروتکل مسیریابی EIGRP به صورت زیر می باشد:

Bandwidth:  10000000 / کمترین پهنای باند لینک های موجود در مسیر*256

Delay: جمع کل*256 Delay های مسیر

Metric EIGRP: Bandwidth + Delay

به مثال زیر توجه کنید:

پیکربندی پروتکل مسیریابی EIGRP

در تصویر بالا همان طور که مشاهده می کنید برای محاسبه Metric مسیری که از R1>R2>R3>R4 عبور می کند به شکل زیر Metric محاسبه می شود.

کمترین پهنای باند مسیر معادل : 64 kbps

جمع کل  Delay های مسیر معادل : 6000

فرمول محاسبه Metric را در پایین مشاهده می کنید.

Bandwidth:   10000000 / کمترین پهنای باند لینک های موجود در مسیر*256

Delay: جمع کل*256 Delay های مسیر

بر اساس فرمول بالا اطلاعات را جایگزین می کنیم همان طور که در خط های زیر مشاهده می کنیم.

Bandwidth:  ( 10000000/64)*256=40000000

Delay: (200+200+2000)*1536000

Metric= bandwidth+Delay

Metric=40000000+1536000=41536000

مراحل زیر را دنبال کنید:

مرحله 1 : پیکربندی تنظیمات IP Address بر روی روتر 1 و روتر 2 و روتر 3

برای پیکربندی اینترفیس FastEthernet 0/0 بر روی روتر1 دستورات زیر را اجرا کنید.

Router1#configt

Router1(config)#interface fastethernet  0/0

Router1(config-if)#ip address 192.168.2.1  255.255.255.0

Router1(config-if)#no shutdown

برای پیکربندی اینترفیس Serial 2/0 بر روی روتر 1 دستورات زیر را اجرا کنید.

Router1#configt

Router1(config)#interface fastethernet  2/0

Router1(config-if)#ip address 192.168.0.1  255.255.255.0

Router1(config)#clock rate 64000

Router1(config-if)#no shutdown

برای پیکربندی اینترفیس FastEthernet 0/0 بر روی روتر 2 دستورات زیر را اجرا کنید.

Router2#configt

Router2(config)#interface fastethernet  2/0

Router2(config-if)#ip address 192.168.3.1  255.255.255.0

Router2(config-if)#no shutdown

برای پیکربندی اینترفیس Serial 2/0 بر روی روتر2 دستورات زیر را اجرا کنید.

Router2(config)#interface Serial 2/0

Router2(config-if)#ip address 192.168.0.2  255.255.255.0

Router2(config-if)#no shutdown

برای پیکربندی اینترفیس Serial 3/0 بر روی روتر 2 دستورات زیر را اجرا کنید.

Router2(config)#interface Serial 3/0

Router2(config-if)#ip address 192.168.1.1  255.255.255.0

Router2(config)#clock rate 64000

Router2(config-if)#no shutdown

برای پیکربندی اینترفیس FastEthernet 0/0 بر روتر 3 دستورات زیر را اجرا کنید.

Router3#configt

Router3(config)#interface fastethernet  0/0

Router3(config-if)#ip address 192.168.4.1  255.255.255.0

Router3(config-if)#no shutdown

برای پیکربندی اینترفیس Serial 2/0 بر روی روتر 3 دستورات زیر را اجرا کنید.

Router3(config)#interface Serial 2/0

Router3(config-if)#ip address 192.168.1.2  255.255.255.0

Router3(config-if)#no shutdown

مرحله 2 : پیکربندی پروتکل مسیریابی EIGRP بر روی روتر 1

برای پیکربندی پروتکل مسیریابی EIGRP در مد Global Configuration mode با دستور Router EIGRP پروتکل مسیریابی EIGRP بر روی روتر فعال می شود و شما وارد Routing mode روتر می شوید ولی بر خلاف RIP در تعریف پروتکل مسیریابی EIGRP نیاز به ست نمودن پارامتری به نام AS می باشد که AS یک عدد اختیاری می باشد و تنها روترهای که دارای شماره AS مشترک می باشند اطلاعات روتینگ خود را با یکدیگر به اشتراک می گذارند.

در پیکربندی پروتکل مسیر یابی EIGRP شما باید شبکه های که مستقیماً به اینترفیس های روتر 1 متصل می باشند یا به عبارتی شبکه های که در داخل جدول مسیریابی روتر 1 به عنوان شبکه های Connected شناسایی و تشخیص داده شده اند در روتینگ مد در مقابل دستور Network در پیکربندی پروتکل مسیریابی EIGRP وارد نمایید همان طور که در زیر مشاهده می کنید.

Router1#configt

Router1(config)#router eigrp 100

Router1(config-router)#network 192.168.0.0  255.255.255.0

Router1(config-router)#network 192.168.2.0  255.255.255.0

Router1(config-router)#exit

Router1(config)#exit

پیکربندی پروتکل مسیریابی EIGRP

با دستور زیر پیکربندی ها موجود در حافظه RAM برای ذخیره همیشگی به داخل حافظه NVRAM کپی خواهد شد.

Router1#copy running-config startup-config

مرحله 3 : پیکربندی پروتکل مسیریابی EIGRP بر روی روتر 2

در پیکربندی پروتکل مسیریابی EIGRP شما باید شبکه های که مستقیماً به اینترفیس های روتر متصل می باشند یا  به عبارتی شبکه هایی که در داخل جدول مسیریابی روتر 2 به عنوان شبکه های connected شناسایی و تشخیص داده شده اند در Routing mode در مقابل دستور Network در پیکربندی پروتکل مسیریابی EIGRP وارد نمایید همان طور که در زیر مشاهده می کنید.

Router2#configt

Router2(config)#router eigrp 100

Router2(config-router)#network 192.168.0.0  255.255.255.0

Router2(config-router)#network 192.168.1.0  255.255.255.0

Router2(config-router)#network 192.168.3.0  255.255.255.0

Router2(config-router)#exit

Router2(config)#exit

با دستور زیر پیکربندی های موجود در حافظه RAM برای ذخیره سازی همیشگی به داخل حافظه NVRAM کپی خواهد شد.

Router2#copy running-config startup-config

مرحله 4 : پیکربندی پروتکل مسیریابی EIGRP بر روی روتر 3

در پیکربندی پروتکل مسیریابی EIGRP شما باید شبکه های که مستقیماً به اینترفیس های روتر 3 متصل می باشند یا به عبارتی شبکه های که در داخل جدول مسیریابی روتر 3 به عنوان شبکه های connected شناسایی و تشخیص داده شده اند در Routing mode در مقابل دستور Network در پیکربندی پروتکل مسیریابی EIGRP وارد نمایید.

Router3#configt

Router3(config)#router eigrp 100

Router3(config-router)#network 192.168.1.0  255.255.255.0

Router3(config-router)#network 192.168.4.0  255.255.255.0

Router3(config-router)#exit

Router3(config)#exit

با دستور زیر پیکربندی های موجود در حافظه RAM برای ذخیره همیشگی به داخل حافظه NVRAM کپی خواهد شد.

Router3#copy running-config startup-config

مرحله 5 : مشاهده جدول Routing table روترها

دستور show ip Router را بر روی روتر 1 اجرا کنید و با دقت به خروجی این دستور و قسمت های مشخص شده توجه نمایید.

Router1#show ip route

Gateway of last resort is not set

C  192.168.0.0/24 is directly connected, Serial2/0

D  192.168.1.0/24[90/41024000] via 192.168.0.2, 00:01:42, Serial2/0

C  192.168.2.0/24 is directly connected, FastEthernet0/0

D  192.168.3.0/24[90/40514560] via 192.168.0.2, 00:01:37, Serial2/0

D  192.168.4.0/24[90/41026560] via 192.168.0.2, 00:01:10,Serial2/0

به خروجی دستور show ip router خوب توجه کنید چرا در مقابل بعضی از مسیرها کاراکتر D وجود دارد؟

دستور show ip router را بر روی روتر 3 اجرا کنید و با دقت به خروجی این دستور و قسمت های مشخص شده توجه نمایید.

Router3#show ip route

Gateway of last resort is not set

C  192.168.0.0/24 is directly connected, Serial2/0

D  192.168.1.0/24[90/41024000] via 192.168.1.1, 00:01:42, Serial2/0

D  192.168.3.0/24[90/40514560] via 192.168.1.1, 00:01:37, Serial2/0

C  192.168.4.0/24 is directly connected, fastethernet0/0

به خروجی دستور show ip router خوب توجه نمایید چرا در مقابل بعضی از مسیرها کاراکتر D وجود دارد؟

مرحله 6 : تست نمودن ارتباط بین کامپیوترها با دستور Ping

در این مرحله ما می خواهیم ارتباط بین PC1 و PC2 را با استفاده از دستور Ping بررسی کنیم.

در این مرحله توسط PC1 کامپیوتر PC2 را Ping خواهیم کرد همان طور که در خط زیر مشاهده می کنید.

PC1>Ping 192.168.3.2

Pinging 192.168.3.2 with 32 bytes of data:

Reply from 192.168.3.2:bytes=32 time=20ms TTL=254

Reply from 192.168.3.2:bytes=32 time=20ms TTL=254

Reply from 192.168.3.2:bytes=32 time=20ms TTL=254

Reply from 192.168.3.2:bytes=32 time=20ms TTL=254

در این مرحله توسط PC1 کامپیوتر PC5 را Ping خواهیم کرد همان طور که در خط زیر مشاهده می کنید.

PC1>Ping 192.168.4.2

Pinging 192.168.4.2 with 32 bytes of data:

Reply from 192.168.4.2:bytes=32 time=20ms TTL=254

Reply from 192.168.4.2:bytes=32 time=20ms TTL=254

Reply from 192.168.4.2:bytes=32 time=20ms TTL=254

Reply from 192.168.4.2:bytes=32 time=20ms TTL=254

مرحله 7 : آشنایی با دستورات پیکربندی EIGRP

دستورات پیکربندی EIGRP را در جدول زیر مشاهده و بررسی خواهیم کرد.

پیکربندی پروتکل مسیریابی EIGRP

دستورات نمایش و مدیریت علمکرد پروتکل EIGRP را در جدول زیر مشاهده می کنید.

پیکربندی پروتکل مسیریابی EIGRP

مقاله های بیشتر:

بررسی Subnetting و VLSM در شبکه

پیکربندی Default Route

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0