پیکربندی Default Route در پروتکل مسیریابی OSPF

هدف از این مقاله:

پیکربندی Default Route در پروتکل مسیریابی OSPF

تجهیزات مورد نیاز برای این مقاله:

تنظیمات مربوط به اینترفیس های Router1  را در جدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات مربوط به اینترفیس های Router2  را در جدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات مربوط به اینترفیس های Router3  را در جدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات مربوط به اینترفیس های Switch 1  را درجدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات مربوط به اینترفیس های Switch 2  را درجدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات مربوط به اینترفیس های Switch 3  را درجدول زیر مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC1 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC2 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC3 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC4 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC5 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

تنظیمات کامپیوتر PC6 :

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

در این مقاله قصد داریم Default Route را فقط بر روی یک Router همان روتری که به صورت مستقیم در اینترنت متصل می باشد تعریف کنیم و سپس توسط پروتکل مسیریابی OSPF که یک پروتکل مسیریابی Dynamic می باشد به کل روترهای شبکه تبلیغ کنیم به طوری که همه روترهای سازمان از وجود Default Route تعریف شده اطلاع پیدا کنند.

به زبان ساده تر Default Route تعریف شده بر روی Router2 که به صورت مستقیم به Modem ADSL متصل می باشد در پروتکل مسیریابی OSPF تزریق و در قالب پیام های Update به سایر روترهای دیگر ارسال خواهد شد.

 

مرحله ی1: پیکربندی تنظیمات IP Address بر روی Router1 و Router2 و Router3

پیکربندی اینترفیس FastEthernet0/0 روتر Router1 :

Router1#config t

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ip address 192.168.2.1 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router1 :

Router1(config)#interface serial 2/0

Router1(config-if)#ip address 192.168.0.1 255.255.255.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet0/0 روتر Router2 :

Router2#config t

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ip address 192.168.3.1 255.255.255.0

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس FastEthernet1/1 روتر Router2 :

Router2#config t

Router2(config)#interface fastEthernet 1/1

Router2(config-if)#ip address 192.168.10.2 255.255.255.0

Router2(config-if)#no shutdown

 

پیکربندی اینترفیس Serial2/0 روتر Router2 :

Router2(config)#interface serial 2/0

Router2(config-if)#ip address 192.168.0.2 255.255.255.0

Router1(config-if)#no shutdown

 

پیکربندی اینترفیس Serial3/0 روتر Router2 :

Router2(config)#interface serial 3/0

Router2(config-if)#ip address 192.168.1.1 255.255.255.0

Router2(config-if)#clock rate 64000

Router2(config-if)#no shutdown

پیکربندی اینترفیس FastEthernet0/0 روتر Router3 :

Router3#config t

Router3(config)#interface fastEthernet 0/0

Router3(config-if)#ip address 192.168.4.1 255.255.255.0

Router3(config-if)#no shutdown

پیکربندی اینترفیس Serial2/0 روتر Router3 :

Router3(config)#interface serial 2/0

Router3(config-if)#ip address 192.168.1.2 255.255.255.0

Router3(config-if)#no shutdown

مرحله 2: پیکربندی OSPF بر روی Router1 در محیط Single Area

در این مرحله پروتکل مسیریابی OSPF را در محیط Single Area پیکربندی خواهیم نمود توجه داشته باشید که در این مقاله کلیه Routerهای ما در Area 0 یا همان Backbone Area قراردارند.

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router1:

Router1#config t

Router1(config)#router ospf 10

Router1(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router1(config-router)#network 192.168.2.0  0.0.0.255 area 0

Router1(config-router)#exit

 

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router2:

Router2#config t

Router2(config)#router ospf 10

Router2(config-router)#network 192.168.0.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router2(config-router)#network 192.168.3.0  0.0.0.255 area 0

Router2(config-router)# exit

 

پیکربندی پروتکل مسیریابی OSPF بر روی روتر Router3:

Router3#config t

Router3(config)#router ospf 10

Router3(config-router)#network 192.168.1.0  0.0.0.255 area 0

Router3(config-router)#network 192.168.4.0  0.0.0.255 area 0

Router3(config-router)#exit

 

مرحله 3: پیکربندی Default Route بر روی Router2

در این مرحله می خواهیم یک Default Route برای مسیریابی اینترنت تعریف کنیم که کلیه بسته های ناشناس که مسیری برای مسیریابی آنها در جدول مسیریابی روتر وجود ندارد به سمت اینترنت که در این مثال دستگاه اتصال دهنده ما به اینترنت مودم ADSL هست ارسال شوند.

برای پیکربندی Default Route بر روی Router2 از دستور زیر استفاده کنید.

Router2#config t

Router2(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1

در مثال بالا هر بسته ای با هر مقصدی(0.0.0.0) و با هر ماسک شبکه ای (0.0.0.0)که برای دسترسی به آن در جدول مسیریابی روتر، مسیری وجود ندارد به ست مودم ADSL با آدرس 192.168.10.1 ارسال خواهند شد.

نکته: Default Route فقط بر روی روتری که به صورت مستقیم به اینترنت متصل می باشد تعریف خواهد شد و نیازی به تعریف دستی Default Route بر روی سایرRouterها نمی باشد.

 

مرحله 4: تزریق Default Route در پروتکل مسیریابی OSPF برای توزیع و تبلیغ به سایرRouterها

در این مرحله می خواهیم Default Route تعریف شده بر روی Router2 که در مرحله قبل همین لابراتوارایجاد شد را توسط پروتکل مسیریابی OSPF به سایر روترها تبلیغ کنیم و کلیه روترها از وجود Default Route تعریف شده بر روی Router2 آگاه خواهند شد و در جدول مسیریابی کلیه Routerها به صورت اتوماتیک Default Route اضافه خواهد شد.

برای اعمال Default Route به سایر روترها باید Default Route تعریف شده بر روی Router2 را توسط پروتکل مسیریابی OSPF به سمت سایر ارسال کنید برای این منظور از دستور زیر بر روی Router2 استفاده کنید.

Router2(config)#router ospf 10

Router2(config-router)#default-information originate

دستور بالا باعث خواهد شد که Default Route نوشته شده درRouter2 در پروتکل مسیریابی OSPF تزریق شود و Default Route همراه با بسته های Update پروتکل مسیریابی OSPF به سایر Routerها ارسال شود.

 

مرحله 5: مشاهده جدول مسیریابی Router1 و Router3

دستور show ip router را بر روی Router1 اجرا کنید و با دقت به خروجی این دستور توجه نمایید

Router1#show ip route

Gateway of last resort is 192.168.0.2  to network 0.0.0.0

192.168.0.0/30 is subnetted, 1 subnets

C   192.168.0.0 is directly connected, Serial2/0

192.168.1.0/30 is subnetted, 1 subnets

O 192.168.1.0 [110/128] via 192.168.0.2,03:36:04,Serial2/0

C 192.168.2.0/24 is directly connected, FastEthernet2/0

O 192.168.3.0/24 [110/65] via 192.168.0.2,03:34:17,Serial2/0

O 192.168.4.0 [110/129] via 192.168.0.2,03:33:36,Serial2/0

O*E2 0.0.0.0/0[110/1]via 192.168.0.2, 00:00:05, Serial2/0

 

 

در خروجی دستور show ip route بر روی Router1 در خط مشخص شده که به صورت O*E2 مشخص شده است یک مسیر Default Route  توسط پروتکل مسیریابی OSPF در جدول مسیریابی Router1 اضافه شده است.

دستور show ip route بر روی Router3 اجرا کنید و با دقت به خروجی این دستور توجه نمایید.

Router3#show ip route

Gateway of last resort is 192.168.1.1  to network 0.0.0.0

192.168.0.0/30 is subnetted, 1 subnets

O 192.168.0.0 [110/128] via 192.168.1.1,03:45:41,Serial2/0

192.168.1.0/30 is subnetted, 1 subnets

C 192.168.1.0 is directly connected, Serial2/0

O 192.168.3.0/24 [110/129] via 192.168.1.1,03:45:15,Serial2/0

O 192.168.3. 0/24  [110/65] via 192.168.1.1,03:44:31,Serial2/0

C 192.168.4.0/24 is directly connected, FastEthernet0/0

O*E2 0.0.0.0/0[110/1]via 192.168.1.1, 00:10:34, Serial2/0

در پنجره زیر پیکربندی های مربوط به Router1 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router2 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router2 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

 

در پنجره زیر پیکربندی های مربوط به Router3 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی OSPF

پیکربندی پروتکل مسیریابی OSPF-قسمت دوم

پیکربندی پروتکل مسیریابی OSPF-قسمت اول

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0