پیکربندی Default Route در پروتکل مسیریابی EIGRP

تنظیمات و پیکربندی Default Route در پروتکل مسیریابی EIGRP

هدف از انجام این مقاله پیکربندی Default Route و توزیع آن در پروتکل مسیریابی EIGRP می باشد. تجهیزات مورد نیاز برای انجام این مقاله دو عدد روتر ، دو عدد سوئیچ  سیسکو مدل 2960 ، دو عدد PC و یک اتصال دسترسی به اینترنت می باشد.

تنظیمات اینترفیس های Router1 و Router2

پیکربندی Default Route در پروتکل مسیریابی EIGRP

تنظیمات مربوط به اینترفیس های روتر ISP

پیکربندی Default Route در پروتکل مسیریابی EIGRP

تنظیمات کامپیوتر PC1

پیکربندی Default Route در پروتکل مسیریابی EIGRP

تنظیمات کامپیوتر PC2

پیکربندی Default Route در پروتکل مسیریابی EIGRP

در این لابراتوار قصد داریم Default Route را فقط بر روی یک روتر همان روتری که به صورت مستقیم به اینترنت متصل می باشد تعریف کنیم و سپس توسط پروتکل مسیریابی EIGRP که یک پروتکل مسیریابی Dynamic می باشد به کل روترهای شبکه تبلیغ کنیم به طوری که همه روترهای سازمان از وجود Default Route تعریف شده اطلاع پیدا کنند.

به زبان ساده تر Default Route تعریف شده بر روی روتر 2 که به صورت مستقیم به سرویس دهنده اینترنت متصل می باشد در پروتکل مسیریابی EIGRP تزریق و در قالب پیام های Update به سایر روترهای دیگر ارسال خواهد شد.

 

مرحله 1: پیکربندی روتر 1 و روتر 2 و تنظیم IP Address بر روی اینترفیس های روتر

برای پیکربندی اینترفیس FastEthernet 0/0 بر روی روتر 1 دستورات زیر را اجرا کنید.

Router1#config t

Router1(config)#interface fastEthernet 0/0

Router1(config-if)#ip address 192.168.14.1 255.255.255.0

 

Router1(config-if)#no shutdown

برای پیکربندی اینترفیس های Serial 0/0 بر روی روتر دستورات زیر را اجرا کنید.

 

Router2(config)#interface serial 0/0

Router2(config-if)#ip address 192.168.15.1 255.255.255.0

Router2(config-if)#clock rate 64000

 

Router2(config-if)#no shutdown

برای پیکربندی اینترفیس های fastEthernet 0/0 بر روی روتر2 دستورات زیر را اجرا کنید.

 

Router2#config t

Router2(config)#interface fastEthernet 0/0

Router2(config-if)#ip address 192.168.16.1 255.255.255.0

Router2(config-if)#no shutdown

 

برای پیکربندی اینترفیس های fastEthernet 1/1 بر روی روتر2 دستورات زیر را اجرا کنید.

 

Router2#config t

Router2(config)#interface fastEthernet 1/1

Router2(config-if)#ip address 192.168.100.2 255.255.255.0

Router2(config-if)#no shutdown

برای پیکربندی اینترفیس های Serial 0/0 بر روی روتر 2 دستورات زیر را اجرا کنید.

Router2#config t

Router2(config)#interface Serial 0/0

Router2(config-if)#ip address 192.168.15.2 255.255.255.0

Router2(config-if)#no shutdown

مرحله 2: پیکربندی پروتکل مسیریابی EIGRP بر روتر1 و روتر2

استفاده از دستورات زیر پروتکل مسیریابی EIGRP را بر روی روتر1 تعریف خواهیم کرد.

 

Router1#config t

Router1(config)#router eigrp 100

Router1(config-router)#network 192.168.14.0 255.255.255.0

Router1(config-router)#network 192.168.15.0 255.255.255.0

Router1(config-router)#exit

Router1(config)#exit

مرحله 3: پیکربندی Default Route بر روی روتر2

در این مرحله می خواهیم یک Default Route برای مسیریابی اینترنت تعریف کنیم که کلیه بسته های ناشناس که مسیری برای مسیریابی آنها در جدول مسیریابی روتر وجود ندارد به سمت روتر ISP ارسال شوند.

برای پیکربندی Default Route بر روی روتر2 از دستور زیر استفاده کنید.

 

Router2#config t

Router2(config)#ip route 0.0.0.00.0.0.0 192.168.100.1

 

در مثال بالا هر بسته ای با هر مقصدی و با هر ماسک شبکه ای که برای دسترسی آن در جدول مسیریابی روتر مسیری وجود ندارد به سمت روتر سرویس دهنده اینترنت ISP با آدرس 192.168.100.1 ارسال خواهند شد.

نکته : Default Route فقط بر روی روتری که به صورت مستقیم به اینترنت متصل می باشد تعریف خواهد شد و نیاز به تعریف دستی Default Route بر روی سایر روترها نمی باشد.

 

مرحله 4: تزریق Default Route در پروتکل مسیریابی EIGRP برای توزیع و تبلیغ به سایر روترها

در این مرحله می خواهیم Default Route تعریف شده بر روی روتر 2 که در مرحله قبل همین مقاله ایجاد شد را توسط پروتکل مسیریابی EIGRP به سایر روترها تبلیغ کنیم و کلیه روترها از وجود Default Route تعریف شده بر روی روتر 2 آگاه خواهند شد و در جدول مسیریابی کلیه روترها وسط پروتکل مسیریابی EIGRP به صورت اتوماتیک Default Route تعریف خواهد شد.

برای اعمال Default Route به سایر روترها باید Default Route تعریف شده بر روی روتر 2 را توسط پروتکل مسیریابی EIGRP به سمت سایر روترها توزیع مجدد کنیم برای این منظور از دستور زیر بر روی روتر 2 استفاده می کنیم.

Router2(config)#router eigrp 100

Router2(config-router)#redistribute static

دستور بالا باعث خواهد شد که Default Route نوشته شده در روتر2 در پروتکل مسیریابی EIGRP تزریق شود و Default Route همراه با بسته های Update پروتکل مسیریابی EIGRP به سایر روترها ارسال شود.

 

مرحله 5: مشاهده جدول مسیریابی روتر1 و روتر2

دستور show ip router را بر روی روتر1 اجرا کنید و با دقت به خروجی این دستور توجه نمایید.

Router1#show ip route

Gateway of last resort is 192.168.15.2 to network 0.0.0.0

C    192.168.14.0/24 is directly connected, FastEthernet0/0

C    192.168.15.0/24 is directly connected, Serial0/0

C    192.168.16.0/24[90/20514560] via 192.168.15.2,01:26:47,Serial0/0

D*EX 0.0.0.0/0 [170/20537600] via 192.168.15.2,01:26:26,Serial0/0

در خروجی دستور Show IP route بر روی روتر1 در خط مشخص شده که به صورت D*EX مشخص شده است یک مسیر Default Route توسط پروتکل مسیریابی EIGRP در جدول مسیریابی روتر1 اضافه شده است.

دستور Show IP route را بر روی روتر2 اجرا کنید و با دقت به خروجی این دستور توجه نمایید.

Router2#show ip route

D    192.168.14.0/24[90/20514560] via 192.168.15.1,01:29:44,Serial0/0

C    192.168.15.0/24 is directly connected, Serial0/0

C    192.168.16.0/24 is directly connected, FastEthernet0/0

C    192.168.16.0/24 is directly connected, FastEthernet1/1

S*   0.0.0.0/0[1/0]via 192.168.100.1

 

در پنجره زیر پیکربندی روتر 1 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی EIGRP

 

در پنجره زیر پیکربندی روتر 2 را مشاهده می کنید.

 

پیکربندی Default Route در پروتکل مسیریابی EIGRP

مقالات بیشتر در زمینه پروتکل های مسیریابی:

 

پیکربندی پروتکل مسیریابی EIGRP (بخش اول)پیکربندی پروتکل مسیریابی EIGRP (بخش دوم)

نظر دهید

پاسخ دهید

سوالات متداول

رویه های بازگرداندن کالا

شرایط و قوانین 

حریم خصوصی 

نظرات خود را با ما در میان بگذارید:

شماره تماس: 62913-021                               آدرس ایمیل: info@atranet.org

فناوران عصر شبکه آترا
Logo
مقایسه موارد
  • کل (0)
مقایسه
0